Personal tools

BuildingLinux

From Bunkerwiki

Jump to: navigation, search

Install the dependencies

For Mumble/Murmur 1.1.0 and greater (including SVN), Qt 4.3 is required. For Mumble 1.1.8 or newer, QT 4.4 is required.

For Debian / Ubuntu

The following command makes sure you have the needed libraries and dependencies installed to build Mumble and Murmur from source!

aptitude install qt4-dev-tools libqt4-dev libspeex1 libspeex-dev libboost-dev libasound2-dev libxevie-dev libxevie1 libssl-dev g++ libspeechd-dev libzeroc-ice-dev libpulse-dev slice2cpp libcap-dev libspeexdsp-dev libprotobuf-dev protobuf-compiler libboost1.37-dev libogg-dev

It's recommended to remove the package qt3-dev-tools if installed.

You can also install the libg15-dev libraries for Logitech G15 Keyboard series.

Now go on to the section #Installing_from_source.

Installing from source

The most generic approach to install mumble under any Linux is to install from source. Either get the current mumble source over git or get the latest tarball release from sourceforge.net.

GIT

For compiling from git make sure you've installed git-core (includes git-clone)

apt-get install git-core
git clone git://mumble.git.sourceforge.net/gitroot/mumble/mumble mumble
cd mumble
git submodule init
git submodule update

To use the v1.1.x branch (which you most likely do):

git checkout --track -b v1.1.x origin/v1.1.x

Or to use the current branch:

git checkout --track -b master origin/master

If you want to update your local branch, make sure you're still in the main git directory ('mumble' in the above example) and use this command:

git pull

If you want to build Mumble 1.2 with the 1.1.x client you have to run the

src/mumble11x/mklinks.sh

script before compilation.

tarball release

Download the latest tarball release from sourceforge.net and extract it

tar xzfv mumble-x.x.x.tar.gz       # (whereas the X are the version numbers of mumble)
cd mumble-x.x.x

Compile Mumble and Murmur

For more configuration options on the qmake command read the supplied INSTALL file.

Be sure to have the pre-requisites installed and in place for your linux distribution (see the sections above) before you begin compiling it.

qmake main.pro
make

If you want to compile Murmur (Mumble server) only, then type

qmake main.pro CONFIG+=no-client
make

Note: If you are using Debian/Ubuntu with both Qt3 and Qt4 installed use the command "qmake-qt4" instead of "qmake"

Text to Speech

For text-to-speech voices you will need to install speech dispatcher and at least a voice. Most distros ship packages for that in their repositories.

Run Mumble

cd release
./mumble

Run Murmur


Back-32x32.png